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INTRODUCTION

Welcome to MicroGrade

...the gradebook that makes the tasks of entering and updating student and class information easier than
ever. Here are just a few of the time-saving features available:

One-Step Data Entry
You only need to enter student data once. You can even import data from another source into a
MicroGrade file using the File Genius feature! When you change student data, MicroGrade
automatically updates related information for you.

Communicate With Your Students
With MicroGrade’s E-mail capability, you can send a confidential message to one student or
broadcast common information, such as the course syllabus, grading standards, office hours, test
results, etc. to an entire class. The WebGrade feature lets you quickly produce a selection of
formatted reports for easy posting to any web site.

Simplify Administrative Tasks
MicroGrade makes it a snap to search for and find information about students.

Fast and Easy Reporting
MicroGrade’s flexibility offers many different ways to create and print reports. You decide which
headings to use and the information each report contains.

Choices for Calculating Grades
MicroGrade provides several widely used techniques for calculating grades.

Advanced Analysis Capability
MicroGrade’s reports can help you analyze student and class performance. You can export
information from MicroGrade for analysis in other programs and provide student data to school-
wide administrative systems.

Effective, Built-In Security Measures
MicroGrade includes a password protection feature that allows you to assign passwords for each
class file and for each student in the class for security and protection.
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System Requirements

Macintosh Windows
•  System 7.0 or later •  Windows 95/98/NT
•  4 MB of available memory •  8 MB of RAM
•  4 MB of disk space •  4 MB of disk space
•  Screen resolution 640 x 480 pixels •  Screen resolution 640 x 480 pixels
•  A printer (optional) •  A printer (optional)

Making Backup Copies

It is wise to make backup copies of MicroGrade’s installation disk and the disks you use to save your
work. Remember to work from your hard drive when using MicroGrade. Working directly from a floppy
disk is not recommended. Use floppy disks only to create backup copies of your class file, and store
your backups in a safe place. If you are not familiar with the procedures needed to make copies of your
disks, please refer to your system software manual for instructions.

Refer to Section Four of this User Guide for information regarding MicroGrade’s Save As feature. This
feature can save all or part of your class file and structure.

Frequently Asked Questions About MicroGrade

If you have specific concerns that have not been addressed in this User’s Guide, visit our web site at
http://micrograde.classmanager.com/help for troubleshooting advice and answers to frequently asked
questions. You can also E-mail us for additional technical assistance. (Refer to “Getting Help” below.)

At our web site you will find information about:
• error messages
• printing problems
• what to do if your screen is blank after launching the program
• what to do if you forget your password
• incorrect grade calculation
• the user license error message
• running MicroGrade from a server
• starting new grading periods with the same students
• moving one or more students to a new class
• averaging grading periods
• and much more !!!



Introduction     3

Getting Help

Chariot Software Group is pleased to provide quality technical support to our customers. When you have
time, be sure to make extra copies of the MicroGrade Technical Support Request Form that follows. To
ensure that you receive prompt service, either fax the support form to us, or use the form below to 
email us the required information.  Contact Chariot in one of the following ways:

•  Fax: 858-270-2027
•  Web Site - http://www.chariot.com/home/supportrequest.asp

http://www.chariot.com/home/supportrequest.asp?ref=1
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MicroGrade Technical Support Request Form

Name:______________________________________________________________________________

School:___________________________________ Department:________________________________

Address:____________________________________________________________________________

City: _________________________________________   State: ____________ Zip: _______________

E-mail_______________________________ Phone___________________Fax ___________________

Best time to reach you: ________________________________________________________________

Computer Model:

PC/Compatible: 486 Pentium

Macintosh: iMac     eMac      PowerMac      iBook     PowerBook

Other: ____________________________________________________________

RAM (computer memory): _______________________________________________________

Operating System:

PC/Compatible:     Windows 98    Windows NT   Windows ME  Windows 2000  Windows XP

Macintosh:              System 8.___.___ System 9.___.___ System X.___.___

Program Version: _________________________________Program Date: _______________________

Serial Number (From the Help Menu, About MicroGrade screen):______________________________

Description of the problem:
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PROGRAM OVERVIEW

Tutorial

This section has been designed to give you a brief introduction to some of the basic functions and
features available in your new computerized gradebook software. Take a few moments to complete the
introductory tour so that you can better navigate your way through MicroGrade when you are working
on your own class files.

1. Double-click on the MicroGrade program icon found in the folder/group created when you
installed MicroGrade. (If you are using Windows, you can access MicroGrade from the
Programs menu.)
The Select MicroGrade File dialog displays.

2. Click on the file named Sample Class and then click Open Class.

MicroGrade’s Tiled Windows
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3. Take a look at MicroGrade’s Tiled Windows. You can modify the window arrangement by
resizing or closing any of the open windows. Use the Windows menu to re-open windows, to tile
your windows or to save your window arrangement.

Click on the Window pull-down menu now to familiarize yourself with the menu items
available.

Window Pull-Down Menu

4. When you create a new class, you should define your preferences before entering any student or
score information. From the Edit menu, click on the Preferences For hierarchical menu and
choose Display & Sorting, Reports, Grades and Scores, Student Information or Email.
Familiarize yourself with the settings available in each of these dialogs.
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Preferences Dialogs
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1. After you define the preferences for a new class file, you can enter your student records. From the
Students menu, choose Student Records.

Edit Student Records Dialog
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Use this dialog to enter, edit and drop students from your class. You can also use this dialog to
enter notes about each student or to assign attributes that can be used to create a subset of your
class when needed. (More about how to create attributes can be found in Section Two of this
User’s Guide.)

6. Next, you may want to enter categories and assignments for your class. From the Edit menu,
choose Setup Categories.

Setup Categories Dialog

Use this dialog to enter the categories and assignments you want to include in your class file.
You can determine percentage weights for categories, assign extra credit categories, and specify
how many low scores to drop per category for each student.

7. MicroGrade also allows you to set Grade Standards. From the Edit menu, choose Grade
Standards. Use your mouse and keyboard to select categories and assignments and to practice
entering information in the grid columns.
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Grade Standards Dialog

Your grade standards can be defined by numbers, letters or symbols and you can also choose to
curve certain assignments. (More about how to set grade standards can be found in Section Two
of this User’s Guide.)

8. After you define grade standards you can enter student scores. Click inside the Class Scores
window or the Student Summary window and use your mouse and keyboard to practice entering
student scores.

MACINTOSH:  Remember, you can resize the windows and make them larger by using the
zoom box or the resize box in the upper and lower right corners of each window, respectively.

WINDOWS:  Remember, you can resize the windows and make them larger by using the zoom
boxes in the upper right corner of each window, or by using your mouse to click and drag each
window to a desired size.
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Class Scores Window

Student Summary Window
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Use the Scores menu for special scoring options. With MicroGrade you can mark scores as
incomplete, excused or late. You can also view student grades by class rank in the Student
Summary window, fill scores, unscore a single student’s score or clear all scores for a selected
assignment.

9. MicroGrade also provides a wide variety of reporting options that you can use to output
gradebook information to screen, disk, printer, HTML file or Email. Click on the Reports menu
to familiarize yourself with the reports that you can create from your class files. In addition, the
Upload reports option under the WebGrade menu enables you to post certain reports to Chariot
Software's web site for viewing by your students.

10. This tour has hopefully given you a brief overview of what you can do with MicroGrade. The
software also offers many more advanced features. In addition to entering basic student and
score information, you can also create grading periods, setup attendance records, configure a
seating chart, and set passwords for your class files. You also have access to a variety of import
and export options. If you read on in Section Two of this User’s Guide, you will find step-by-
step instructions to help you create every aspect of your computerized gradebook. Your
MicroGrade package also includes a Quick Reference Card to help guide you through some of
MicroGrade’s basic features.
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USING MICROGRADE

Starting MicroGrade

Creating a New Class Using Quick Start
To begin creating a new class, click the Quick Start button when the Welcome to MicroGrade dialog
appears.  The Quick Start dialog lets you create a new class in 5 steps.  Each step is displayed on the left
and the action required for each step is shown on the right.  Instructions are displayed at the top of each
action item.  A check mark appears by each step as it is completed.

; NOTE: If you do not want to use the Quick Start feature, click the Experienced User button to
begin using MicroGrade.  To return to Quick Start, use the MicroGrade Help menu.

Step 1. Name Your Class
1. Click inside the Class Name text box and enter the class name for your MicroGrade file.

(Example: Math102)

; NOTE: MicroGrade will automatically save this file for you in the location where
MicroGrade was installed.

2. If your class has multiple grading periods, enter a title for the first grading period in the Grading
Period Name text box.  (Example: First 9 Weeks)

3. Click on the Next button to continue.

Step 2. Set Class Preferences
1. Click on the radio buttons to select a grading method and display format for student names.

; NOTE: MicroGrade includes a variety of additional preferences that will be available to
you when you are finished with the Quick Start feature.

2. Click on the Next button to continue.

Step 3. Set Grade Standards
1. Click on the Set Grade Standards button to review the grade standards MicroGrade has created

for you.

; NOTE: You can change the default settings to reflect what will work best for you and
your students.

2. Once you have selected your desired standards, click on the OK button.
3. Click on the Next button to continue.
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Step 4. Add Categories And Assignments
MicroGrade allows you to organize all your assignments within categories.

1. Click on the Add Categories and Assignments button to enter category and assignment
information for your class.

2. To add categories, click on the Add Categories radio button.  Type the name of the category in
the Category Title: text box and an abbreviation in the Abbrev: text box.  Click on the Enter
button.

; NOTE: Category abbreviations are optional.

3. To add an assignment within a category: First, select a category from the list in the upper left
corner of this window by clicking on it.  Second, click on the Add Assignments radio button.
Third, enter the Assignment Title, Abbreviation, Maximum Score and Date in the appropriated
fields.  Click on the Enter button.

; NOTE: Assignment abbreviations and dates are optional.

4. To edit a category or assignment, first select a category or assignment from the list in the upper
left corner of this window by clicking on it.  Second, click on the Edit Existing radio button and
make the desired edits.  Click on the Enter button.

5. Once you have entered your categories and assignments, click on the OK button.

; NOTE: Entering all of your categories and assignments at this time is optional.

6. Click on the Next button to continue.

; NOTE: The instructions above correspond to the Grade by Total Points Grading Method
selected in Step 2 of the Quick Start process.  If you selected the Grade by
Percentage Weights Grading Method and need additional assistance, please refer
to the MicroGrade manual.

Step 5. Add Student Records
Student records can be entered manually or by using MicroGrade’s File Genius import feature.  We
suggest entering a few sample students to familiarize yourself with MicroGrades user interface.

1. Click on the Add Student Records button to begin entering student information.

; NOTE: A last name and a first name are required for each student.

2. MicroGrade automatically generates student ID’s and WebGrade Passwords.  To change the
information, click inside the WebGrade Password: textbox and type the desired information.
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; NOTE: You can return to the Student Record dialog at any time to enter additional
information.

3. After you have entered all of your student’s information, click on the Finished button.
4. Next, the Congratulations! You have completed the steps to create your new class dialog will

appear.  View this dialog to familiarize yourself with MicroGrade’s user interface.
5. Click on the Finished button to begin working with your new class.

Creating or Opening a Class File
1. Double-click the MicroGrade program icon found in the MicroGrade folder/group created when

you installed MicroGrade. (If you are using Windows, access MicroGrade using the Programs
menu.) The Select MicroGrade File dialog will display.

2a. From the Select MicroGrade File dialog, choose New Class to create a new MicroGrade class
file.
-or-

2b. If you want to practice with the Sample Class, from the Select MicroGrade File dialog, click on
the sample class file and then choose Open Class.

Setting a Password
To protect your class files, MicroGrade allows you to set a password for each file. To create a password:

1. From the File menu, choose Set Password.
2. From the Set Password dialog, click inside the text box and enter your password. To save this

information, click OK.
3. A dialog box appears prompting you to re-enter your password for verification. Click inside the

text box to re-enter your password and then click OK.

Changing/Deleting a Password
1. Open the MicroGrade class file containing the password you want to change or delete.
2. From the File menu, choose Set Password.
3. Click inside the text box and type the existing password. Click OK.
4. From the Set Password dialog, click inside the text box to enter a new password (you can also

leave the text box blank if you do not want to assign a password.) When finished, click OK.
5. If you have modified a password, MicroGrade will prompt you to re-enter your password for

verification. Click inside the text box and enter the new password. When finished, click OK.
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MicroGrade’s Tiled Windows

With MicroGrade, you can work with options from the menu bar and you can choose to work in a
window-driven environment. MicroGrade’s windows provide immediate access to your categories and
assignments as well as class scores and student information. You can choose to work in MicroGrade’s
tiled window format or you can create your own window arrangement. Choose to work with any of the
following windows: Class Roster, Student Summary, Categories and Assignments and Class Scores.

MicroGrade’s Tiled Windows

Class Roster
When you begin a new class in MicroGrade, the Class Roster window will display in the upper left
corner of your screen. Once you have entered student records, the Class Roster window will display a
list of the active students in your class. You can view your student roster by Name, ID, Score, or User
selected. From the Windows menu, you can choose sort options and set a user specified order for your
class roster.
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Student Summary
Once you have entered student records and categories and assignments, you can view and edit student
scores using this window. Use the arrow button icons to select a student and use the vertical scroll bar to
view all of your assignments and scores for the selected student.

Categories and Assignments
Once you have entered categories and assignments, you can view a complete list using the Categories
and Assignments window. This window will show you if an assignment has been partly or fully scored,
or has not been scored at all.

Class Scores
The Class Scores window will display your class roster with score columns for each assignment in the
active grading period. You can use the horizontal scroll bar to view all assignment columns, and you can
click in the appropriate cell to make changes to student scores. Choose sort options from the Windows
menu to modify the order of your class roster.

Window Arrangement
Once you have entered your student records and your categories and assignments, you can use
MicroGrade’s Window menu to create and save a window arrangement for your class file. If you wish to
create the standard tiled window format, follow the steps below.

1. If your Class Roster window is not open in the upper left corner of your screen, from the
Window menu, choose Class Roster.

2. From the Window menu, choose Student Summary.
3. From the Window menu, choose Categories and Assignments.
4. From the Window menu, choose Class Scores.
5. From the Window menu, choose Tile Windows.
6. From the Window menu, choose Save Window Arrangement.

; NOTE: You can choose to have any combination of the four windows open at any time. If you
wish to set up an alternative window arrangement, resize your windows accordingly and
choose Save Window Arrangement from the Window menu.

MicroGrade Tool Bar

You can use MicroGrade's Tool Bar to gain quick access to many commonly used gradekeeping
functions. The tool bar will automatically appear beneath the MicroGrade menu bar when you open a
class file. If you do not want the tool bar to appear you can change the default setting in the Preferences
For Display and Sorting dialog box.
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MicroGrade’s Tool Bar

Use the tool bar to access the following features and functions:

New Class

Open Class

Save Class

Exit MicroGrade

Cut

Copy

Paste

Edit Preferences

Edit Student Records

Edit Categories and Assignments

Edit Grade Standards

Send E-Mail

WebGrade Upload

Transfer Students

Tile Windows

Help
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Deactivating the Tool Bar
1. From the Edit menu, choose Preferences For: Display and Sorting.
2. Click inside the Show Tool Bar checkbox to deactivate the tool bar.
3. Repeat steps 1-2 to reactivate the tool bar.

; NOTE: If you are working with a class file created using an older version of MicroGrade, the
Tool Bar will not appear automatically when you first open the file. Use the Preferences
For Display and Sorting dialog to select the Show Tool Bar option.

MicroGrade Preferences

MicroGrade’s Preferences are a way to set defaults for student and class information. Use Preferences to
define the sequence of student names and IDs, what information is included in reports and to specify
how final grades are determined. You can move easily from one preferences dialog to another by using
the drop-down menu displayed at the top of each Preferences for dialog.

Display and Sorting
Use the Preferences for Display and Sorting dialog to determine the font and type size used on-screen
and several other options.

1. From the Edit menu, choose Preferences For.
2. From the hierarchical menu, choose Display and Sorting. The Preferences for Display and

Sorting dialog will display.
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Preferences For Display & Sorting

3. Review and/or change options, then select another Preferences For option from the drop-down
menu at the top of the dialog. If finished, click OK.

Reports
Use the Preferences for Reports dialog to determine the font and type size used on printed reports along
with other reporting options.

1. From the Edit menu, choose Preferences For.
2. From the hierarchical menu, choose Reports. The Preferences for Reports dialog will display.
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Preferences For Reports

Grades and Scores
This dialog allows you to specify the way final grades are calculated and how MicroGrade calculates
and displays scores.

1. From the Edit menu, choose Preferences For.
2. From the Preferences For hierarchical menu, choose Grades and Scores.

The Preferences for Grades and Scores dialog will display.
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Preferences For Grades & Scores

The sections in this dialog allow you to specify the defaults MicroGrade uses when calculating and
displaying scores.

Base Final Grade on Options:
Choose from four final grading options from the Base Final Grade on drop-down menu:

•  Percent Weight of Categories and Assignments: Use this method to assign a percent value to
categories and assignments. For example, suppose you want to use class categories such as essays,
exams and homework to calculate an overall grade for each class. In this example, you can assign
essays a value of 35%, exams 30%, and homework 35%. The student’s average grade for each
group of assignments is multiplied by the percent value of the category type. You then add the
weighted category averages together to obtain the student’s overall grade for each class. Percent
weights are based on 100%, but can exceed 100% to assign extra credit.

•  Relative Weight of Categories and Assignments: Use this method to set a relative weight value
for categories and assignments. For example, suppose your class contains four categories. Each is
assigned a relative weight of one. MicroGrade multiplies a student’s average in each category by
.25, and then adds these together to get a final grade.

•  Total Points of Assignments: In this method, you divide the total points a student receives by the
total points of all assignments to obtain an overall grade in the class. In this grading method,
categories play no part in grade calculation. They only serve to group assignments.
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•  Relative Weight of Assignments: Use this method to give each assignment a weight that
contributes to the overall grade in each class. For example, suppose you want to base an overall
grade on five tests, ten homework assignments, and a final research paper. In this case, you would
assign each a relative weight of one. MicroGrade adds a student’s percent score on all assignments
and then divides it by sixteen to get their overall grade. As with total points, categories play no part
in grade calculation.

Scoring Options:
Use this section to determine how scores are used in grade calculations and how final scores are
displayed. Click on the Grade cutoffs With 1 Decimal checkbox, and scores will be cutoff and displayed
to the nearest tenth (one place to the right of the decimal point). Click on the Use Rounded Percent
Scores checkbox, and scores will be rounded and displayed to the nearest whole number. Click on the %
Scores With 1 Decimal checkbox, and percent scores will be displayed to the nearest tenth. Click on the
Raw Scores With 2 Decimals checkbox, and raw scores will be displayed to two decimal places.

Score Entry Warnings:
Use this section to specify if you want to be warned when scores have been changed.

Incomplete Options:
Use this checkbox and text box to determine how incomplete assignments are scored. If you enter a
number in the Incomplete Students Get text box, incomplete assignments will receive the score
specified. Incomplete scores are not considered in the calculation of grades if this box is left unchecked.

Unscored Options:
Use this section to determine how to score missing assignments. If you click the On Partly Scored
Assignments checkbox, the student will receive a percentage score of the amount entered in the
Unscored Students Get text box. If you click the On or After Assignment Date checkbox, students with a
missing score past an assignment date will receive a percentage score of the amount in the Unscored
Students Get text box.

Exclude from Statistics Options:
Use this section to exclude students with incomplete, unscored, excused, and dropped assignments from
statistical calculations. These statistics are displayed in the Statistics and Gradebook reports and Class
Scores window (optional). Select options by clicking on the appropriate checkboxes.

From the Grades and Scores dialog, review and/or change options, then select another Preferences For
option from the drop-down menu at the top of the dialog. If finished, click OK.

Student Information
Use the Student Information dialog to define the format of the student IDs and names for all the students
in your class. The four choices for entering student name formats are Word Caps, ALL UPPER, all
lower and As EntereD. Student IDs allow you to assign a unique identifier (up to 13 characters) to each
student. Student IDs are required only if you plan to average classes or import/export student records.



Using MicroGrade   25

There are three ways to enter student ID numbers and WebGrade passwords: Manually, Automatically,
and Auto Sequential.  If you would like to exclude a student from the WebGrade Reports click on the
Exclude This Student checkbox.

1. From the Edit menu, choose Preferences For.

2. From the Preferences For hierarchical menu, choose Student Information.
The Preferences For Student Information dialog will display.

Preferences For Student Information

3. Review the default settings, make modifications as desired, and click OK.

; NOTE: For information about using MicroGrade’s E-Mail feature, refer to Section Four of this
User’s Guide.
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Student Records

After you have installed the program and have reviewed and/or modified preferences, you can enter
students into your class. Student names can include up to 28 characters and student IDs and WebGrade
passwords up to 13 characters.

Adding Students to a Class
1. From the Students menu, choose Student Records. The Edit Student Records dialog will display.

Edit Student Records Dialog

2. Click on the Add Students radio button in the bottom left corner of the dialog.
3. Click inside the Last text box and then type the student’s last name.
4. Click inside the First text box and then type the student’s first name. If you need to use a middle

initial or middle name, type a space to separate the first name and middle initial or middle name.
5. Click inside the Student ID text box to enter a unique ID for each student.
6. Click on the Gender drop-down menu to select Male or Female.
7. Click inside the Phone 1 and Phone 2 text boxes to enter student or parent phone numbers.
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7. Click inside the E-mail 1 and E-mail 2 text boxes to enter student or parent e-mail addresses.
8. Click inside the WebGrade Password text box to enter a unique password for each student.
9. Click on the Exclude This Student checkbox if you would like to exclude a student from the

WebGrade Reports.
10. To add the student’s name and specified information to the class, click Enter.
11. To continue adding students’ names, repeat steps 2-9.
12. To save the information, click Finished.

; NOTE: Click on the Edit Active Students radio button to modify existing student records.

Dropping Students from a Class
1. From the Students menu, choose Student Records.

The Edit Student Records dialog lists all active students in the class.
2. Click on the student name that you want to remove from the list, and then click Drop. The

student’s name will be selected from the list and the number of students dropped from the class
will be noted at the bottom of the dialog.

3. To save the information, click Finished.

Returning a Dropped Student to a Class
1. From the Students menu, choose Student Records.
2. In the Edit Student Records dialog, click on the Edit Dropped Students radio button. The names

of students that have been dropped displays on the left side of the dialog.
3. Click on the student name you want to return to the roster.
4. To return the student to the class, click Add.
5. To save the information, click Finished.

Entering Student Notes
Student notes can be used to enter unique information about each student. Enter up to two notes per
student (up to 255 characters combined); if confidential, click on the Don’t Show checkbox and the
note(s) will not be included in reports.

1. From the Students menu, choose Student Records.
2. Click on Notes 1 or Notes 2 from the drop-down menu, then click inside the Note text box and

type in your text.
3. To save the note, click Enter. When done entering notes, click Finished.

Defining Student Attributes
Attributes can group students who share characteristics. For example, you may need to keep track of
students who are pulled out of your classroom due to sports or athletic events. In this example, Athletes
would be defined as the attribute and the reasons why students are pulled out of class (such as, game
day, practice, Volleyball team) represent the values assigned to that attribute.

1. From the Students menu, choose Define Student Attributes. The Define Student Attributes dialog
will display.
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Define Student Attributes Dialog

2. To create an attribute, click on the Add New Attribute radio button.
3. Click inside the Title text box, type in the attribute name, and then click Add/Enter.
4. To continue, click OK.

; NOTE: Use the Add Below Selection/Add Above Selection drop-down menu to
determine the placement order of your attributes.

Adding a New Value to an Attribute
1. From the Students menu, choose Define Student Attributes.
2. Use your mouse to click on the desired attribute. The title should now appear in the text box.
3. To add a value, click on the Add Attribute Value radio button on the right side of the dialog.
4. Click inside the Title text box, type the attribute value, then click Enter.
5. To continue, click OK.

; NOTE: Use the Add Below Selection/Add Above Selection drop-down menu to
determine the placement order of your attributes.
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Assigning an Attribute to a Student
1. From the Students menu, choose Assign Student Attributes. The Assign Student Attributes

dialog will display.

Assign An Attribute To a Student

When attributes have been defined, each attribute will appear to the right of the active student list
with drop-down menus which contain the attribute’s values.

2. Click on and highlight a student name.
3. To assign an attribute for a particular student, from the desired attribute drop-down menu, select

and highlight the attribute value you want to assign to the highlighted student.
4. To continue, click OK.

Removing an Attribute Assigned to a Student
1. From the Students menu, choose Assign Student Attributes.
2. Use your mouse to click on and highlight a student’s name. The assigned attributes will appear in

the drop-down menus.
3. From the appropriate drop-down menu, choose the first option which is blank to remove the

attribute.
4. To continue, click OK.
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Using an Attribute to Select Students
Attributes can also be used to create a sub-set of your class when needed. To create this sub-set, an
attribute and its corresponding value must be specified. You can also select students based on other
information stored in MicroGrade, such as attendance, an assignment or an overall class grade. For
example, suppose that you want to know how many freshmen are in your class. (Assume that you have
already created year as an attribute, freshman as a value and assigned that attribute to the appropriate
students). The following example illustrates how to select and to create a report on this sub-set of the
total class.

1. From the Students menu, choose Select Students. The Select Students dialog will display.

Select Student Dialog

2. From the first column of drop-down menus in the first row of menus, choose Student.
3. Use your mouse to move to the drop-down menu immediately to the right and choose Year (or

the desired attribute).
4. Use your mouse to move to the third column of drop-down menus in the first row and choose the

equal symbol (=).
5. Again, use your mouse to click on top of the down arrow immediately to the right of the last text

box and choose freshman (or the desired value) from the drop-down menu.
6. Click on the Calculate button.

MicroGrade automatically calculates how many freshmen are in your class. You could now print
a class roster (or other report) listing these specific students.

; NOTE: If you wish to select students based on a combination of attributes, click on the
ANDs or ORs radio button in the Combine Attributes With box and choose
additional selection criteria from the remaining rows in the dialog.
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7. When finished, click OK.

Defining Comment Codes
Use MicroGrade’s comment codes to store additional notes about your students. You can use the same
code for all students (for example, “Asks a lot of questions”) or you can create codes that are student-
specific (such as, Possible candidate for senior scholarship). Up to 32 different comment codes (up to
255 characters) for each class can be created and each student can receive up to 16 comments. Comment
codes can be included in MicroGrade’s Student Summary and Free Format reports.

1. From the Students menu, choose Define Comment Codes. The Define Comment Codes dialog
will display.

Define Comment Codes Dialog

The nine drop-down menus at the top of the dialog (General, Student, Max Points, Percent,
Letter Grade, Raw Score, Assignment Date, Attendance Codes, Student Attributes) can be used
to incorporate class information into the comment code.

2. Click on the New radio button in the Edit Mode box in the bottom right corner of the dialog.
3. Click inside the text box in the upper half of the dialog, below the drop-down menus. Then, from

the Student drop-down menu, choose First name. Type a space, followed by any pertinent
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information.
4. To save the comment code, click Enter.

MicroGrade will number all new comment codes and display them in their numerical order in the
dialog.

5. To continue, click OK.

Assigning Comment Codes
Once you have defined Comment Codes, you can assign them to individual students in one of two ways.

1. From the Students menu, choose Assign Comment Codes. The Assign Comment Codes dialog
will display.

Assign Comment Codes Dialog

2. Use your mouse to click on and highlight a student’s name.
To select a comment code:

3a. Select and highlight a comment code’s numerical reference from the Comment Codes drop-down
menu found below the row of 16 text boxes.
-or-

3b. If you know the comment code’s numerical reference, click inside the first of the 16 text boxes
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and type in the number (use the remaining 15 text boxes as you select additional comment
codes).

4. Click Enter.

; NOTE: Click on the Fill Comment Codes button to assign one comment code to all of the
students. To edit existing comments or to add new comment codes, click on the
Edit Comment Codes button to access the Define Comment Codes dialog.

5. When finished, click OK.

Grading Periods

With MicroGrade, each class file can be separated into 16 independent grading periods. Grading periods
enable you to extend a class over a long time frame and can eliminate the need to manually duplicate
class records and default settings. In addition, grading periods can be averaged in order to create one
overall grade.

Creating a New Grading Period
1. From the Periods menu, choose Add Grading Period. The Add Grading Period dialog will

display.

Add Grading Period Dialog

2. Click inside the Grading Period text box and type in the name for the grading period (up to 23
characters).



Using MicroGrade   34

3. Click inside the Instructor Name text box and type your name.
4. Use the remaining text boxes and checkbox to enter e-mail and server information.
5. Click on the Options button. The Add Grading Period Options dialog will display.

Add Grading Period Options Dialog

6. From the dialog, select options by clicking on the appropriate checkboxes. You may choose to
share Window Positions, Student Selection, and/or Report Settings and Headings with the first
grading period you created. Choose to duplicate Preferences, Categories and Assignments,
Seating Chart, Comment Code text, Student Comments, Class Grade Standards and/or Report
Settings and Headings from the currently active grading period.

7. Click OK or press the Enter key.
8. Click OK again to save information.
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Modifying a Grading Period
At any point in time, you can make name or option changes to a grading period. To modify a grading
period:

1. From the Periods menu, choose the grading period to be modified. A checkmark will appear to
the left of the active grading period in the Periods menu.

2. From the Periods menu, choose Modify Grading Period. The Modify Grading Period dialog will
display.

Modify Grading Period Dialog

3. Use your mouse to click inside the Grading Period, Instructor Name, Instructor E-Mail Address,
SMTP Server and/or Student E-Mail Domain text boxes and type in modified information.

4. From the Modify Grading Period dialog, click on the Options button. Modify existing
information by clicking on the appropriate checkboxes.

5. To save changes, click OK.

Deleting a Grading Period
1. From the Periods menu, choose the grading period to be deleted. A checkmark will appear to the

left of the active grading period in the Periods menu.
2. From the Periods menu, choose Delete Grading Period.
3. An alert dialog will appear, asking you to verify your delete command. Click Yes to delete the

grading period.
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Create Summary Grading Period
You can create a summary of all grading periods in your class file using the Create Summary Grading
Period option from the Periods menu. This option is a convenient way to average information and obtain
final grades.

1. After you have entered scores for all assignments in each grading period, from the Periods menu,
choose Create Summary Grading Period. The Create Grading Period Summary dialog will
display.

Create Grading Period Summary Dialog

2. Use your mouse to click inside the Grading Period, Instructor Name, Instructor E-Mail Address,
SMTP Server and/or Student E-Mail Domain text boxes and type in information for your
summary grading period.

3. From the Create Grading Period Summary dialog, click on the Options button. Modify existing
information by clicking on the appropriate checkboxes. You may choose to share Window
Positions, Student Selection, and/or Report Settings and Headings with the first Grading Period.
You may also choose to duplicate Preferences, Categories and Assignments, Seating Chart,
Comment Code text, Student Comments, Class Grade Standards and/or Report Settings and
Headings from the currently active Grading Period.

4. Click OK when finished.
5. From the Periods menu, notice the new period, Summary Grading Period, is now the active

period.

Use this Summary Grading Period when you want to display, view or print Grading Period averages.
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Excluding Students from a Grading Period
This procedure allows you to remove a student or students from any grading period (including your
summary grading period).

1. From the Periods menu, choose the grading period which includes the student to be excluded. A
checkmark indicates the active grading period.

2. From the Periods menu, choose Exclude Students. The Exclude Students from Grading Period
dialog will display.

Exclude Students From Grading Period Dialog

The left list box includes the names of all active students in the active grading period.

3. Exclude students by moving their name to the Selected Student box in one of three ways: double-
click on a student’s name, select a student’s name and then click on the >> button or use the
arrow keys on your keyboard.

; NOTE: The student names that appear in the Selected Students list box will be deleted
from the active grading period. If desired, they can be restored later by reversing
the process.

4. To save information, click OK.
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Categories and Assignments

Adding Categories
Categories are used to organize assignments by type, such as homework, mid-terms and final exams.
Remember to select the appropriate grading period from the Periods menu before you set up your
categories and assignments.

1. From the Edit menu, choose Setup Categories. The Setup Categories dialog will display.

Setup Categories Dialog

2. Select the Add Categories radio button.
3. Next, click inside the Category Title text box and type the Category name.
4. Click inside the Abbrev. text box and type an abbreviation for the category.
5. Click inside or tab to the Percent Wgt. or Relative Wgt. text box to type in a percent weight for

the category in the text box provided. (This text box may not be available depending on options
chosen in the Preferences for Grades and Scores dialog.)

6. You can also choose from category-based optional features:
• To create a category that has only one assignment (such as a final or a term paper), click
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on the Single Assignment Category checkbox.

;  NOTE: A Max score and a Date text box appear when this option is selected.

• You can also create extra credit categories by clicking on the Extra Credit Category
checkbox.

;  NOTE: If MicroGrade determines that the extra credit category will lower the student’s
final grade, the extra credit will not be used. If the extra credit will improve the
student’s final grade, it will be included in the final calculations.

7. If you are creating multiple assignment categories, choose from the following options:
• Click inside the Number of Low Scores to Drop text box and enter a value to drop the

lowest percent score a student receives on any scored assignment within a category.
• Determine the amount each assignment contributes to the category. Click on the Weigh

Assignments drop-down menu to select: Equally, By Points or User Specified. (This
drop-down menu may not be available depending on options chosen in the Preferences
for Grades and Scores dialog.)

8. To save information, click Enter.
9. When finished, click OK.

Changing or Deleting a Category
1. From the Edit menu, choose the category title (listed under Setup Categories) to be deleted.
2. From the dialog, click Delete.
3. An alert dialog appears asking if you want to delete all assignments associated with the category,

click Yes.
4. To continue, click OK.

Adding Assignments
Manage and organize assignments within categories. For example, if you assign four research papers in
a semester, you could organize the papers in two different ways: you could create four assignments
under a category entitled Research Papers or each Research Paper could be created as a single
assignment category.

1. From the Edit menu, choose Setup Categories.
2a. To add an assignment under an existing category, click on the category name (or if assignments

have already been added to the category, click on an assignment in the category and the new
assignment will be added below the highlighted assignment). Then click on the Add
Assignments radio button.
 -or-

2b. To create a category that contains only one grade or one assignment, click on Add Categories
radio button and then click on the Single Assignment Category checkbox.

3. Click inside the Assignment Title text box and enter the name of the assignment.
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4. OPTIONAL: Click inside the Abbrev. text box and type in its abbreviation.
5. Click inside the Max. Score text box and type in a maximum score.
6. OPTIONAL: Click inside the Date text box and enter date.

; NOTE: If you have created a single assignment category, MicroGrade may also display a
Percent Wgt. text box. Click inside or tab to the text box and type in a percent
weight.

7. To save information, click Enter.
8. To continue, click OK.

Changing or Deleting an Assignment
1. From the Edit menu, choose Setup Categories.
2. Click on the assignment you want to edit or delete.
3a. To edit an assignment, click on the Edit Existing radio button and make the changes you want in

the dialog and text boxes, then click Enter.
-or-

3b. To delete an assignment, make sure the assignment name is highlighted and then click Delete.
An alert dialog appears asking if you want to delete the named assignment. Click Yes.

4. To continue, click OK.

Defining Grade Standards
Use MicroGrade’s Grade Standards to establish grade scales and symbols. This dialog can also grade
assignments and categories on a curve, when needed.

1. From the Edit menu, choose Grade Standards. The Grade Standards dialog will display.
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Grade Standards Dialog

2. Use your mouse to click on Class Standards.
3. To change a grade symbol, click and highlight a text box. Change existing values or enter new

values.

; NOTE: Create and apply grading standards that work best for you. You can use numbers,
letters (three characters), or symbols (or combine all three).

4. If needed, click Calculate to recalculate scores.
5. To establish grade standards for a specific assignment, use your mouse to select the assignment

from the list box on the left side of the dialog. Setting different grade standards for an assignment
results in curving the grades for that assignment.
To curve an assignment, click inside the Curve This Assignment checkbox while an assignment
is selected. The % Cutoff column will become highlighted, and values in this column can be
changed to reflect a curve. Change the % Cutoff values as desired. New values entered will
become the minimum score required to receive the corresponding grade in the same row.

6. Click OK when finished.



Using MicroGrade   42

Entering Scores

There are two ways to enter scores: from the Student Summary window or from the Class Scores
window. If entering several scores for different assignments, use the Student Summary window. If
entering scores for one particular assignment, use the Class Scores window. Remember to select the
appropriate grading period from the Periods menu before you begin to enter student scores.

From the Student Summary Window
1. From the Window menu, choose Student Summary.

Student Summary Window

2. Scroll through the students in your class by using the arrow buttons in the upper left area of the
window.

3. After the student name has been chosen, use your mouse to click on the assignment. The current
score will become highlighted.

4. Type in the student’s score for the active assignment.
5. To save the new score, press the Return or Enter key or use the arrow keys on your keyboard to

move to another assignment.
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From the Class Scores Window
1. From the Window menu, choose Class Scores.

Class Scores Window

2. Select an assignment by clicking on a cell. Use the horizontal scroll bar at the bottom of the
Class Scores window to view additional assignment columns.

3. Click on the student’s name or type the first letter of his/her last name. The active student name
will become selected and current score for the selected assignment will become highlighted.

4. Type in the student’s score.
5. To save the new score, press the Return or Enter key or use the arrow keys on your keyboard to

move to another student.

Entering Letter Grades
Letter grades can be entered as scores as long as they have been defined in the Grade Standards dialog.
To enter a letter grade you must precede it with an equal sign so that MicroGrade recognizes it properly.
MicroGrade will evaluate the entry and substitute a raw score that is equivalent to the minimum number
of points required to receive that grade on the assignment.

Changing Student Scores
1. From the Window menu, choose Class Scores or Student Summary.
2. Select the appropriate assignment. The active assignment or student will become selected and the

current score will become highlighted.
3. Type over the existing score. An alert dialog will appear, asking you to verify your changes.

Respond to the alert box by clicking the Cancel, No or Yes button.

; NOTE: The alert box will not appear if this option has not been selected in the
Preferences for Grades and Scores dialog.
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4. To save the new score, press the Return or Enter key or use the arrow keys on your keyboard to
move to another student or assignment.

Special Scoring Options
MicroGrade also provides features that can mark a student’s score as late, excused or incomplete.
Review the defaults selected in the Preferences for Grades and Scores dialog to verify how these options
will be displayed and printed.

1. From the Student Summary or Class Scores window, select a student’s score. The active score
will become highlighted.

2. From the Scores menu, choose one of the following options:
Mark Incomplete (INC): Replaces unscored assignment. Any student that has an INC on any
assignment will receive an incomplete as their final grade.
Mark Excused (“e”): Excuses a student from completing an assignment.
Mark Late (“L”): Flags a raw score, excused or incomplete assignments. “Late” assignments do
not affect a student’s final grade.

; NOTE: To remove marks, highlight the score (or mark) and then from the Scores menu,
choose Mark Incomplete (or enter a score), Mark Excused or Mark Late.

Fill Scores: Uniformly scores an assignment for active students.
Show Rank in Class: Ranks students by overall grade to date as displayed in reports and in the
Student Summary window.
Return to Unscored: Returns a selected student’s score to an unscored state.
Clear Assignment: Returns all scores to an unscored state on an assignment for active students.

Attendance Records

Setup Attendance
1. From the Students menu, choose Setup Attendance. If this is the first time this feature has been

accessed, the Initialize Attendance Start Date dialog displays.
2. Click inside the Attendance Start Date text box and enter the appropriate date in the

Month/Day/Year format and click OK. The Setup Attendance dialog will display.
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Setup Attendance Dialog

The attendance period is valid for one calendar year. Use the Setup Attendance dialog to define the
attendance options that you want to use. Click inside the text boxes to enter data. MicroGrade confirms
your attendance record start and end dates just above the Reset Start Date, Cancel and OK buttons.

3. Click inside the Date of First Class and Date of Last Class text boxes and type start and end dates
for your class. If the last date you enter extends beyond one year, MicroGrade displays an alert
dialog.

4. Click the Class Meeting Days checkboxes that correspond to the days of the week your class will
meet.

5. To enter Non-School Days (such as holidays and staff development days), click inside the Start
Date and Thru Date text boxes and enter dates. Up to 36 Non-School Days can be defined.

6. To describe the Non-School Day, click inside the date’s Description text box, type in your
information and click Enter. You can use up to 15 characters for its description.

7. To save the Setup Attendance information, click OK.
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Define Attendance Codes
MicroGrade lets you define up to 16 attendance codes. Up to 23 characters can be used to describe each
code. The code itself can have up to three characters.

1. From the Students menu, choose Define Attendance Codes. The Define Attendance Codes dialog
displays. Notice that MicroGrade comes with four preset codes that can be modified or deleted,
if desired.

Define Attendance Codes

2. To enter a new code, click on the New Attendance Codes radio button. A highlighted line will
appear in the list box on the left side of the dialog.

3. Click inside the Abbreviation text box, and type in up to three characters for the code.
4. Click inside the Description text box, and type in a description for the code using up to 23

characters.
5. To add the new code, click Enter. The dialog displays the new attendance code. MicroGrade

displays the number of codes already defined and the number of remaining codes at the bottom
of the dialog.

6. To continue, click OK.
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Mark Attendance
Before you Mark Attendance, you need to first Setup Attendance and ensure that you have defined
attendance codes.

1. From the Students menu, choose Mark Attendance. The Mark Attendance dialog displays.

Mark Attendance Dialog

Use the horizontal scroll bar at the bottom of the dialog to view future weeks in the spreadsheet
calendar.

2. Use your mouse to move through the grid box to the cell where you want to insert an attendance
code. Click in the cell and select a code from the Attendance Codes drop-down menu.

3. To assign the same code to all students for a particular day, click on any student’s box in the
appropriate day’s column, select an attendance code from the Attendance Codes drop-down
menu and click Fill Column.

4. When finished marking attendance, click OK.
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Creating a Seating Chart

MicroGrade includes an option that allows you to configure a seating chart for your class. The seating
chart option can create a report including student letter grades, percentage grades, ID numbers, student
gender, and student phone numbers on your seating chart report.

1. From the Students menu, choose Seating Chart. The Configure Seating Chart dialog will display.

Configure Seating Chart Dialog

2. In the Number of Seats text box, enter up to 480 seats to be included in your chart.
3. Use the Font Size drop-down menu to select a font for your seating chart and click inside the

Seat Width and Seat Height text boxes to specify size requirements.
4. Use the checkboxes and radio buttons available to specify Seat Information Options, Student

Information Options, and Seat Alignment Options.
5. Click OK when finished. The Seating Chart dialog will display.
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Seating Chart Dialog

6. From this dialog, choose to Add Seat, Delete Seat, or Print your seating chart. You can also
return to the Configure dialog.

7. Click and drag to move seats around on your seating chart.

; NOTE: If you have selected Free Form as a Seat Alignment Option, you can move seats
around freely. If you have selected Snap to Grid, the seats you move will
automatically snap into the row/column format.

8. Click OK when finished.

; NOTE: After you configure your seating chart, you can also print a Seating Chart Report
by choosing Seating Chart from the Reports menu.
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MICROGRADE REPORTS

MicroGrade includes fourteen report templates that you can customize. It is important to remember the
following when creating reports:

• Review preference defaults to specify how student records are displayed on-screen and how
reports look when printed.

• Create reports with data for all students in your class or for a specified selection of students by
choosing an option from the Students To Print: drop-down menu.

• Include customized report headers with font options. Font options for reports may be changed
from the Preferences For Reports dialog, within the Edit menu.

• Choose to print your reports, save them to disk, view them on-screen, send by e-mail or output
them to HTML format by selecting options from the Output To: drop-down menu.

• In addition to the Reports menu, the WebGrade menu allows you to post the Roster, Student
Summary, Class Standards, and Statistics reports to Chariot's WebGrade site.

; NOTE: For information about using MicroGrade’s E-Mail feature, refer to Section Four of this
User’s Guide.

Include customized report headers with font options. Font options for reports may be changed from the
Preferences For Reports dialog, within the Edit menu.

Choose the destination of your report from the Output To: drop-down menu. All reports can be output to
the printer and to the screen. All reports except the Seating Chart can be output to disk. The Roster,
Class Standards, Grades by Assignment and Free-form reports can be sent via e-mail. Output to HTML
is available for the Roster, Student Summary, Class Standards, Overall Class Grades, and Grades by
Assignment reports. In addition to the Reports menu, the WebGrade menu allows you to post the Roster,
Student Summary, Class Standards, and Statistics reports to Chariot's WebGrade site.
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Choosing a Report

All reports are listed in the Reports pull-down menu. If a particular report is not accessible you may
need to enter more student-specific or class-specific information in MicroGrade. Be sure to check your
active Grading Period or Summary Grading Period prior to accessing report options.

Creating a Class Roster Report
The Class Roster report lists all active students in your class.

1. From the Reports menu, choose Class Roster. The Class Roster Report dialog will display.

Class Roster Report Dialog

2. Choose print options using the checkboxes available.
3. Make a selection from the Students to Print drop-down menu.
4. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
5. From the Output To: drop-down menu, select Printer, Screen, Disk, HTML, or E-mail and click

OK.
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Class Roster Report

Creating a Student Summary Report

The Student Summary report can be used to create missing assignments, progress, or final grade reports.

1. From the Reports menu, choose Student Summary. The Student Summary Report dialog will
display.

Student Summary Report Dialog
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2. Choose categories from the Categories display box, and make assignment selections from the
Assignments drop-down menu.

3. Choose print options using the checkboxes available.
4. Modify page format using the One Student Per Page or Gap Between Students radio button.
5. Make a selection from the Students to Print drop-down menu.
6. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, on the first page only or with
each student.

7. From the Output To: drop-down menu, select Printer, Screen, Disk, or E-mail and click OK.

Student Summary Report
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Creating a Dropped/Excluded Students Report
The Dropped/Excluded Students report lists students dropped from a class file.

1. From the Reports menu, choose Dropped/Excluded Students. The Dropped Students Report
dialog will display.

Dropped Students Report Dialog

2. Choose print options from the checkboxes available.
3. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
4. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.

Creating a Class Standards Report
The Class Standards report lists all assignments, their maximum points, percent value in the final grades,
scoring status, dates and the class grading scale, if desired.

1. From the Reports menu, choose Class Standards. The Class Standards Report dialog will display.

Class Standards Report Dialog

2. Click on the Print Categories and Print Grade Scale checkboxes, if desired, and click on the Edit
Header button to type a report header.

3. From the Output To: drop-down menu, select Printer, Screen, Disk, HTML, or E-mail and click
OK.
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Class Standards Report

C reating an O ve rall C lass G rades Re port
The Overall Class Grades report lists student ID with or without name, class ranking, and current grade.
A student’s grade can also be projected (indicated by #) by choosing the Projected Scores checkbox.

1. From the Reports menu, choose Overall Class Grades. The Class Grades Report dialog will
display.

Class Grades Report Dialog



MicroGrade Reports   56

2. Choose print options using the checkboxes available.
3. Make a selection from the Students to Print drop-down menu.
4. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
5. From the Output To: drop-down menu, select Printer, Screen, Disk, or HTML and click OK.

Overall Class Grades Report

Creating a Grades by Assignment Report
The Grades by Assignment report lists student names, ID numbers, and grades for selected assignments.
In addition, you can include your grading standard and print this report for a single assignment, for all
assignments, or for scored assignments only.

1. From the Reports menu, choose Grades by Assignment. The Grades by Assignment Report
dialog will display.
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Grades By Assignment Report Dialog

2. Make selections from the Assignments to Print drop-down menu.
3. Choose print options using the checkboxes available.
4. Make a selection from the Students to Print drop-down menu.
5. From the Output To: drop-down menu, select Printer, Screen, Disk, HTML or E-mail.
6. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
7. From the Grades by Assignment Report dialog, click OK when finished.
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Grades By Assignment Report

Creating a Gradebook Report
The Gradebook report resembles a traditional gradebook. It lists student names or ID numbers, grades
for each assignment and a final grade. This report can be customized to fit your reporting needs.

1. From the Reports menu, choose Gradebook. The Gradebook Report dialog will display.
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Gradebook Report Dialog

2. Choose print options from the drop-down menus and checkboxes available.
3. Choose Assignment Date Options.
4. Make a selection from the Students to Print drop-down menu.
5. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
6. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.
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Gradebook Report

Creating a Statistics Report
The Statistics Report includes bar charts and tables listing statistical information about class assignments
or categories.
Bar Chart: The vertical axis represents the number of students and the horizontal axis represents the
range of scores. Generate reports by Grade Names, % Scores or Raw Scores.
Statistics Table: This table displays the maximum and minimum score, the range, median and average
scores as well as the standard deviation. Information is generated in raw scores, percentages, and letter
grades.

1. From the Reports menu, choose Statistics. The Statistics Report dialog will display.
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Statistics Report Dialog

2. Choose from the options offered in this dialog using the drop-down menus and radio buttons
available.

3. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down
menu and choose to display the header on all pages of your report, or on the first page only.

4. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.

Creating a Work Sheet Report
The Work Sheet report contains the student name or ID followed by a series of up to 8 titled or up to 52
untitled columns.

1. From the Reports menu, choose Work Sheet. The Work Sheet Report dialog will display.



MicroGrade Reports   62

Work Sheet Report Dialog

2. Choose from the options offered in this dialog using the text boxes, checkboxes, and radio
buttons available and enter column titles if desired. Empty rows can be included and will appear
at the bottom of each page.

3. Make a selection from the Students to Print drop-down menu.
4. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report or on the first page only.
5. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.

Work Sheet Report
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C re at ing a Free Form Report
A Free Form report combines your text with fields selected from drop-down menus. Each drop-down
menu contains fields defined within MicroGrade. Use this feature to create personal notes that can be
used for communication with students or parents.

1. From the Reports menu, choose Free Form Report. The Free Form Report dialog will display.

Free Form Report Dialog

2. Make selections from the General, Student, and Scores drop-down menus to identify information
fields for your report. (MicroGrade automatically inserts double-angled brackets around
information selected from the drop-down menus.

3. Click inside the text box and enter your own text where appropriate. You may cut and paste text
from a word processor document as well. If you have created a text file that you wish to include
in your report, select Open File.

4. Make a selection from the Students to Print drop-down menu.
5. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
6. From the Output To: drop-down menu, select Printer, Screen, Disk, or E-mail and click OK.
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Free Form Report

Creating an Attendance by Student Report
The Attendance by Student Report allows you to list the individual attendance records for one or a group
of your students. In the report dialog you can specify print options, add a report header and make
attendance code selections.

1. From the Reports menu, choose Attendance by Student. The Attendance by Student Report
dialog will display.
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Attendance By Student Report Dialog

2. Select Attendance Codes from the display box on the left side of the dialog by using your mouse
to click on desired choices, or by clicking on the Clear All or Select All buttons.

3. Make print selections using the drop-down menus, checkboxes and radio buttons available.
4. Make a selection from the Students to Print drop-down menu.
5. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report or on the first page only.
6. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.
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Attendance By Student Report

Creating an Attendance by Day Report
The Attendance by Day Report allows you to list specified class dates with students categorized by the
selected attendance codes. You can choose to print all valid class dates or a specified range of dates.
MicroGrade also allows you to choose print options for student and attendance code information.

1. From the Reports menu, choose Attendance by Day. The Attendance by Day Report dialog will
display.
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Attendance By Day Report Dialog

2. Select Attendance Codes from the display box on the left side of the dialog by using your mouse
to click on desired choices, or by clicking on the Clear All or Select All buttons.

3. Select Date Range options using the All radio button, or the From/Thru text boxes.
4. Make print selections using the radio buttons and checkboxes available.
5. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report or on the first page only.
6. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.
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Attendance By Day Report

C reat ing an At tend ance Grid Report
You can create an Attendance Grid Report to display class attendance for a specified range of weeks.
Your report can include all attendance and summary information, or you can choose to print a blank grid
with dates only.

1. From the Reports menu, choose Attendance Grid. The Attendance Grid Report dialog will
display.
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Attendance Grid Report Dialog

2. Choose print options by using the drop-down menus and checkboxes available.
3. From the Attendance Totals By section, specify criteria using the radio buttons available.
4. Specify the desired week range by using the From/Thru radio buttons and pop-up menus

available.
5. Make a selection from the Students to Print drop-down menu.
6. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose to display the header on all pages of your report, or on the first page only.
7. From the Output To: drop-down menu, select Printer, Screen, or Disk and click OK.
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Attendance Grid Report

Creating a Seating Chart Report
With MicroGrade, you can create a Seating Chart report for your class. It can display student names,
grades, and information. If you have not configured your seating chart using the Students menu, the
Seating Chart menu item in the Reports menu will be dimmed. If you wish to configure your seating
chart, refer to Section Two of this User’s Guide before proceeding with the steps below.

1. From the Reports menu, choose Seating Chart. The Seating Chart Report dialog will display.

Seating Chart Report Dialog
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2. Choose print options by using the checkboxes available.
3. Click on the Edit Header button to enter a report header. Click inside the Header On: drop-down

menu and choose a header display option

Seating Chart Report

4. From the Output To: drop-down menu, select Printer or Screen and click OK.



MicroGrade Reports   72

HTML Reports

HTML is an output option available for the Class Roster, Class Standards, Overall Class Grades and
Grades by Assignment reports. In addition to printing reports to disk, printer, or on-screen an Internet-
ready HTML page can be created for these reports. Simply make selections from the appropriate menus
and dialog boxes to configure your report, select HTML from the Output To: menu, and click OK.
You will be prompted to enter a filename, and click OK. A file with the extension “.htm” will be
created.

The “.htm” file is a complete, self-contained Web page. If you have Web pages of your own, you may
create links to your HTML report. However, the report only contains information. It does not contain
any links, so the only way to navigate from the HTML report is to use the “Back” button on your Web
browser.

If you are involved in Web development, you may wish to add links to your WebGrade report, or insert
it in an existing Web page. You may open the file and edit the code using any text editor, such as
NotePad for Windows or SimpleText for the Macintosh. There are comments in the HTML code to
guide you in making the appropriate alterations to your report if you want to include it in an existing
page.

Using WebGrade

In addition to the traditional way of conveying grading information via printed reports, WebGrade
enables you to make MicroGrade reports accessible to your students over the Internet. The WebGrade
feature includes three main elements: (1) the Upload Reports option under the WebGrade menu in
MicroGrade on your local computer, (2) Chariot's WebGrade Internet site located on a server (computer)
at Chariot Software Group where you can view your reports, post notices and e-mail students and (3)
Chariot's eClassInfo Internet site www.eClassInfo.com where students with a password assigned by you
in the Student Records dialog can login and view the reports that you have uploaded to the web. Before
uploading reports, ensure that you have an Internet connection and that ID and WebGrade passwords
have been assigned to your students.  If you would like to exclude a student from the WebGrade
Reports, refer to the Student Records section.

1. From the WebGrade menu, choose Upload Reports.
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WebGrade Reports Dialog

2. When the WebGrade Reports dialog appears, enter a class title. The class title does not appear on
any of the reports but appears on the eClassInfo web page to identify each upload. A report from
the same class and period will replace a prior report from that class and period. If you are
uploading reports from more than one class or from a different period in the same class, give
each report a unique title so your students can easily locate the report for their class.

3. Use the check boxes and radio buttons to select the reports and options desired.
4. Individual report headers can be entered by clicking on the Edit Header buttons associated with

each report. The Class Message button to the right of the Class Title enables you to enter a
message that will appear below the title and above the list of reports.

5. Click on the Upload button in the lower right of the dialog.
A progress bar will appear while the report(s) information is initially saved on your desktop
(Mac) or MicroGrade folder (Windows).

6. If you have a Web browser with a connection to the Internet and your modem is on, MicroGrade
will start your browser and a login page will appear.
a. If you have not created an account, click on the Create Account button. You will be asked

to enter the following information: (1) MicroGrade serial number (if you don't know
yours, look in the About MicroGrade option under the Help menu), (2) name, (3) school,
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(4) zip code, (5) login name (your choice), (6) e-mail address, (7) password (your choice)
and (8) the name that you want to give your web page within WebGrade. When done,
click the Finish button.

b. If you have already created an account, just enter your login name and password and
click the Login button.

7. MACINTOSH:  A new web page will appear with one text box.
a. Click on the Browse button to open the Macintosh file dialog.
b. Click on the Desktop button.
c. Click on the file named WebGrade-Upload-File and click Open.
d. Click on the Upload File button.
WINDOWS: A new web page will appear with two text boxes.
a. Highlight all of the text in the first box and press Ctrl-C to copy it.
b. Click on the second text box and press CTRL-V to paste the text there.
c. Click on the Upload File button.

8. A new page will appear notifying you that the process was successfully completed. Click on the
Continue button.

9. When the WebGrade Reports Index appears, you can do any of the following:
a. go to the page where students access your WebGrade information by clicking on the link

in the upper part of the Index page,
b. click on the Notice button to the right of the report title to post notices which will appear

when students access your reports,
c. click on the Status button to the right of the report title to determine when the report was

uploaded,
d. select the E-mail Students option in the Action drop-down list to email or print student

IDs, passwords, and the web page address where reports can be found.
e. select the View Reports option in the Action drop-down list to access a page with links to

each individual report,
f. click in a checkbox to the far right of the report title(s) and then click the Delete button to

remove the uploaded report(s). Once you delete a set of reports, it will no longer be
available for students to view.

To access the WebGrade site without uploading, go to http://webgrade.classmanager.com. Do not use
"www" before the address. Students can access the uploaded information at www.eClassInfo.com by
searching for their instructor’s web page.  Students will need their ID and password to log in.

The WebGrade menu includes a WebGrade Tutorial option which provides additional information on
the features of WebGrade.
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ADDITIONAL FEATURES

Converting Class Files From a Previous Version of MicroGrade

If you have created Macintosh class files using MicroGrade version 3.0 or later, or Windows class files
using MicroGrade version 1.0 or later, you can convert your files for use with your new version of
MicroGrade.
1. Start the MicroGrade application
2. From the File menu, choose Open.
3. Select the class file you wish to convert and click Open Class.
4. MicroGrade will alert you with a conversion message. If you wish to cancel the conversion

process, click No. If you wish to continue with the conversion process, click Yes.
5. If you choose Yes, MicroGrade will prompt you for a location and new file name for your class

file. You can choose to:
a. Save your converted file in a different location with the same name - (We recommend

that you choose this option and save your file in the folder which stores your new
MicroGrade program.)

b. Save your converted file in the old MicroGrade folder/directory with a new name- You
cannot save your converted file in the same location with the same name.

c. Save your converted file in a different location with a new name.
6. MACINTOSH: Click Save.

WINDOWS: Click OK.
7. Your converted class file will appear.

To modify your window arrangement and begin work in your new file, refer to Section Two of this
User’s Guide.

Using MicroGrade’s E-Mail Feature

With this feature of MicroGrade, instructors can send e-mail messages and certain MicroGrade reports
to an entire class or to individual students. In order to send e-mail from within MicroGrade, your
computer must have access to the Internet by modem or by connection through your institution's
network.

; NOTE (to America Online Users): AOL does not provide access to an SMTP server and cannot
be used to send mail with MicroGrade's e-mail function.
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Setting Up MicroGrade’s E-Mail Feature
In order to send e-mail, MicroGrade must be able to connect to your system's SMTP server, and the
program needs to know the E-mail addresses of your students. (SMTP stands for Simple Mail Transfer
Protocol and the SMTP server handles e-mail on the Internet.)

Setting Up the Mail Server Connection
From the Edit menu, choose the Preferences For option and select E-mail. The Preferences for E-mail
dialog will open for entry of the following information:

Instructor E-mail Address. (Optional)

Copy Instructor on All Mail. (Optional) Click in the text box if you want a copy of all mail sent.
Instructor E-mail address must be present.

SMTP Server. (Mandatory) Enter the institution SMTP server name. If you have questions about this
information or you are not sure what your SMTP server is, contact your network administrator or
Internet service provider.

Student E-Mail Domain. (Optional) The e-mail domain is that part of an E-mail address that follows
the @ symbol. For example, in the address jsmith@ucla.edu, ucla.edu is the domain. If a large number
of your students share a common domain, you can save time by entering the domain name once and
MicroGrade will apply that domain automatically to each student name entered.

E-Mail Preferences Dialog
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Entering Student E-Mail Addresses
E-mail addresses for students can be entered manually by typing each address or they can be imported
electronically.

; NOTE: When importing e-mail addresses, create an additional header field called "Email 1" and
"Email 2". Detailed instructions on importing and exporting information in MicroGrade
are provided in Section Four of this manual.

To enter E-mail addresses manually:
1. From the Students menu, select Student Records.

An e-mail text box can be accessed by clicking within the text box with your mouse or by use of
the tab key. If you entered a common domain name in the E-mail preferences dialog, you only
need to enter a student's prefix if they use that common domain. (For example, jsmith@ucla.edu,
would only need the prefix, jsmith, entered. If a student's address doesn't use the constant e-mail
domain, enter his or her entire address and the common domain will not be applied. The second
e-mail text box can be used if a student has a second e-mail address or for a parent's e-mail
address. Together, the two e-mail addresses can be up to 112 characters.

2. After entering the e-mail addresses for your students, click the Finished button to close the
dialog.

Sending E-Mail
MicroGrade provides three ways to send E-mail to your students; from the Students menu, from the
Summary Window and from the Reports menu.

To send a message to one student (or different messages to a few students) select Send E-mail from the
Students menu. When you select this option, an e-mail dialog will appear allowing you to select the mail
recipient and a space to type your subject and message. Use the drop-down menu in the lower left of the
dialog to specify which e-mail addresses (E-mail 1, E-mail 2 or both) to use. To send the message, click
the Send E-Mail button.

To send a message from the Summary window (the upper right window), click on the Send E-mail
button which is activated when the selected student's e-mail address is available. A blank e-mail
template will appear where you can enter a subject and your message. Use the drop-down menu in the
lower left of the dialog to specify the desired e-mail addresses (E-mail 1, E-mail 2 or both). When your
message is complete, click the Send E-Mail button.
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Send E-Mail Dialog

Sending Reports Via E-Mail
MicroGrade can e-mail the following reports:

• The Class Roster Report
• The Student Summary Report
• The Class Standards Report
• The Grades by Assignment Report
• The Free Form Report

1. From the Reports menu, select one of the options listed above
2. Set the Output to drop down menu to E-mail 1, E-mail 2, or E-mail 1&2.
3. If you want this report sent to the entire class, set the Students to Print option to Current class. If

you want to send this report to a group of students but not all students, set the Students to Print
option to Selection. If you choose this option, a dialog will appear in which you will be able to
select which students are to receive your e-mail.

4. Once this is complete, click the OK button and a subject dialog will appear. If you want to send a
copy of the message to yourself, click in the Copy Instructor on All Mail check box. Enter a
subject and press OK to send the e-mail.
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Sending Broadcast Messages to Multiple Students
To send a common message to more than one student, use the Free Form Report.

1. From the Reports menu, select Free Form Report.
2. In the space provided, type your message or create your custom report.
3. Once this is complete, set the Output to option to E-mail 1, E-mail 2, or E-mail 1&2.
4a. If you want this report sent to the entire class, set the Students to Print option to Current class.

- or -
4b. If you want to send this report to a group of students but not all students, set the Students to Print

option to Selection. If you choose this option, a dialog will appear in which you will be able to
select which students to send to out of the current class roster.

5. Once this is complete, click the OK button and a subject dialog will appear. If you want to send a
copy of the message to yourself, click in the Copy Instructor on All Mail check box. Enter a
subject and press OK to send the e-mail.

; NOTE: If you are not connected to the server when your e-mail has been created, MicroGrade
will allow you to save your message to disk for sending at a later date. In the save dialog
that appears, name your file and select the directory in which you wish to save the
message. To send saved messages from disk, select Send E-mail From Disk from the
Students menu.

Importing Information

If your class lists or student scores are stored in another software program, you can save time by
importing this information into MicroGrade. MicroGrade’s File Genius allows you to import any student
data file into MicroGrade.

Importing Student Records
1. After starting a new class or opening an existing class in which you wish to import student data,

select Import Students from the Students menu. The hierarchical import menu will appear listing
import options.

2. From the hierarchical menu choose the appropriate import information depending on what type
of file you are importing from. You may choose from:

• MicroGrade-imports student information from other MicroGrade class files.
• WebCT- imports student information that has been downloaded from WebCT.
• LXR-imports student information from LXR Tests.
• SASI-imports directly from SASI school-wide administration software.
• Skyward-imports from Skyward school-wide administration software.
• User Defined (File Genius)-user may select the fields to import from any text file.
• User Defined Template-imports data using a preformatted and saved user defined
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format which you have previously saved.

MicroGrade Importing Format
• The import file containing student names must be saved as a text file.
• An import header must be inserted above the first line of your text specifying the data and location.

The header must at least include a last name field. If in Preferences for Student Information you
specified that student IDs are required then IDs (up to 13 characters of unique numbers and letters)
must also be included.

• An example of a header with four information fields follows:
First[Tab] Last[Tab] ID[Tab] Notes 1[Tab]

; NOTE: The order of the header fields does not have to follow the example above. The order can
differ, but must be consistent with the import data.

• Separate each column of import data by a [Tab].
• Each student information record must end in a hard return. If the text for your notes is more than one

line, use a “\” to begin a new line.
• Last names are required.
• First names and student notes are optional and can be left blank but must be followed by a [Tab].
• Acceptable fields include: First, Last, ID, Notes, Notes 1, Notes 2, Phone 1, Phone 2, Gender, Email,

Email 1, and Email 2.
• ID's can be up to 13 characters of unique numbers and letters.
• The maximum number of characters for all the Notes fields combined is 256.
• If your import file contains information that is not a part of the student record, enter a “#” before the

text. MicroGrade will skip the text after the “#” until it finds another hard carriage return.

Preparing your Student Records Import File
1. Open or create the class file to be imported in a word processing program.
2. Create an import header above the first line of text to specify data type and location.
3. Review student information and make sure that the data matches your import header. It should

look similar to the example below:

First Last ID Notes
Sue Smith 12345 transfer student/ home phone 234-5678

Jones 56789 freshman
Joe Bowe 78901

; NOTE: Remember that a last name is required. Skip other information by inserting a
[Tab] into the blank field. If the blank field occurs at the end of the record, the
[Tab] is optional (see the Joe Bowe example).

4. After formatting the import file, close and save it as a Text or Text Only file.
5. To import the Text/Text Only file, open the MicroGrade program and open an existing class or

create a new class. From the Students menu, choose Import Students.
6. MACINTOSH: Use your mouse to double-click on a file name or click on a file name that

contains your formatted text and click Open.
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WINDOWS: Use your mouse to double-click on a file name or click on a file name that contains
your formatted text and click OK.
The resulting dialog lists the import file name and any data errors encountered. Data errors will
contain the First, Last and ID fields followed by an error description. When errors occur, modify
your import file and restart the import process. You can interrupt the import by clicking on the
Stop button.

7. When you have finished reviewing the error list and are satisfied with the import, click the
Finished button.

Importing Information from WebCT
Downloading From WebCT: Before information can be imported into MicroGrade, it must be
downloaded from WebCT.

1. Login to your WebCT account and navigate to the Manage Students area.
2. From the Manage Students area click the Download button. The Download Student Record

dialog displays.

Download Student Record Dialog

3. Change the Record separator from the default Comma to Tab.

IMPORTANT:  WebCT cannot process names that contain a comma when the separator is a
comma because the standard quote protocol is not supported.

4. Click the Download button. The File Download dialog displays.
5. Click on the Save the file to disk radio button, and then click OK. The Save As dialog displays.
6. Enter a file name in the File Name text box, and then select the directory where you wish to save

the file.
7. Click Save when finished.



Additional Features   82

Importing Into MicroGrade: Once WebCT data has been downloaded, it can be imported into
MicroGrade.

1. From the Students menu, choose Import Students, and then click on WebCT.  The Specify
Import Fields dialog displays.

Specify Import Fields dialog

2. You will be asked to locate your downloaded WebCT file.

; NOTE: MicroGrade automatically recognizes the fields “First Name”, “Last Name”, and
“User ID” and associates them with appropriate fields. If there are other fields that
you wish to import assign an appropriate field to them using the “Import Fields:”
popup menu.

3. Click OK when finished.

Importing Information From SASI
Using MicroGrade, you can import student information from your SASI system. In order to do so,
relevant student information must first be exported from SASI. Ask your SASI administrator to run the
following query command:

SAVE STU LN FM MN ID TL AD PG SX
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; NOTE: The SASI file must be in comma delimited format, not in the SASI FIXED
format.

After you have exported information from your SASI system, follow the steps below.
1. From the Students menu, choose Import Students.
2. From the Import Students hierarchical menu, choose SASI. The Import SASI dialog will display.

Import SASI Dialog

3. From the Import SASI dialog, select Import Optional Fields by using the checkboxes available.
4. Click Import. The Select a File of Students to Import dialog displays.
5. MACINTOSH: Select your exported SASI file and click Open.

WINDOWS: Select your exported SASI file and click OK.

Importing Information From Skyward
Using MicroGrade, you can import student information from your Skyward system. After you have
exported information from your Skyward system, follow the steps below.

1. From the Students menu, choose Import Students.
2. From the Import Students hierarchical menu, choose Skyward. The Select a File of Students to

Import dialog will display.
3. MACINTOSH: Select your exported Skyward file and click Open.
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WINDOWS: Select your exported Skyward file and click OK.
4. The Import Skyward Student Records dialog appears. Select a Course/Section to Import from the

drop-down menu, and select which fields to import by using the checkboxes available.
5. Click Import. An alert box will appear, informing you of any errors that occured during the

import process. Click Finished to return to your tiled windows.

Import Skyward Student Records Dialog

Importing Using File Genius
Using MicroGrade’s File Genius, you can import students from a text file of any format. The File
Genius function will read the text file to determine how each record is delimited, and allow you to
identify and select which fields to import.

1. From the Import hierarchical menu, select User Defined.
2. The Select a File of Students to Import appears, prompting you to select the file you wish to

import.
3. Select the file you wish to import, and click Open.
4. The Select Import Data Format dialog displays, showing a piece of the text file.
5. Select an import starting point and click Continue.
6. The Specify Import Fields dialog displays. File Genius will attempt to identify the character

being used as a delimiter between fields. Use the radio buttons to select different field delimiters.
7. Assign MicroGrade data field titles to each field using the drop-down menu at the bottom of the

dialog. This specifies where in the MicroGrade program each piece of imported data will be sent.
8. If you wish to save the select import criteria, click the Save Import Field Specification button.
9. When finished click OK.

Importing Using a User Defined Template
This option imports data using a previously specified User Defined import template which you saved
using the Save Import Field Specification button during a User Defined import. To access this template
for repeated import use:



Additional Features   85

1. Select User Defined Template from the Import menu.
2. The Select a File of Students to Import dialog appears. Select the file you wish to import and

click Open.
3. The Select an Import Template dialog displays. Select a previously saved template and click

Open.
4. The Import Student Status window will appear detailing how many students were imported and

if the process is complete.
5. When the import is complete, click Finished.

Importing Student Scores
MicroGrade uses student IDs to match students with their scores in the import file. You cannot,
therefore, import scores if you have not assigned a unique ID number to each student in your class.
MicroGrade cannot assign IDs to students while importing scores.
The import file for scores must be formatted in a text file and does not require an import header. The file
format for importing scores must contain two or three columns (the third column is optional) as in the
example below:

13425[Tab] 120[Tab] e&L
14234[Tab] 115[Tab]
36473[Tab] 100[Tab] e
38471[Tab] 130[Tab] L

The first column must contain the student’s ID number and the second column must contain the
student’s raw score. The third column, if present, can contain excused (e) and/or late (L) flags. Separate
columns with a tab and end each record with a hard return.

; NOTE: MicroGrade will only recognize excused and late as “e&L”.

Preparing your Student Scores Import File
1. After formatting the import file in a word processing program, close and Save As Text or Text

Only.
2. To import the Text/Text Only file, open the MicroGrade program and open an existing class.
3. From the Scores menu, choose Import Scores. From the Get Assignment To Be Scored From

Import File dialog, click on an assignment to be scored and click OK.
4. If the assignment has been fully or partially scored, an alert dialog will appear. Click Cancel to

stop the import process. If you wish to continue, click OK.
5. MACINTOSH: From the Select a File of Scores to Import dialog, select your Text Only file and

click Open.
WINDOWS: From the Select a File of Scores to Import dialog, select your Text file and click
OK.
As the import file is being processed, MicroGrade will list progress or errors on-screen. IDs and
score errors are listed with a brief explanation of each error.
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4. When you have finished reviewing the error list and are satisfied with the import, click the
Finished button.

Importing Scores from a User Defined Format
The File Genius function may also be used to import scores from any text file. Please refer to Importing
Scores Using File Genius in this section of the MicroGrade User’s Guide.

Importing Scores from WebTest
You can easily transfer graded test results from a WebTest into MicroGrade using the export and import
features that are available.  After you have administered a WebTest to your students, you can use
options available in WebTest to export a text file that will contain student result data.

; NOTE: Refer to the MicroTest Pro User's Guide for more information about creating WebTests
and using WebTest on the Internet.

1. Launch your web browser and access your WebTest Test Administration Home Page using the
appropriate Access Code and Password.

2. From the Test Administration Home Page, choose Results & Scoring from the Test Navigation
Bar.

3. From the Administrative Options pull-down menu, choose Export MicroGrade Data.
4. WebTest will prompt you through a series of dialog boxes that will direct you to save your

export file to disk.
5. When WebTest displays the Save As dialog, you will need to rename the export file with a .txt

extension.  For example, the Save As dialog might show "webtest.exe" as the export file name.
You might choose to enter "testdata.txt" or "results.txt" to rename the export file.

IMPORTANT:  The file name that precedes the ".txt" file extension cannot exceed eight
characters.  You must always include ".txt" at the end of the new file name you create.

6. After you enter a new export file name, select a location for the export file.  You should save
your results data file in the directory that contains your MicroGrade software and class files.

7. When the file download is complete, exit WebTest, open the MicroGrade program and open the
appropriate class file.

8. Follow steps 3-6 listed under Preparing your Student Scores Import File to import WebTest
results to MicroGrade.

; NOTE: If you experience difficulties during the import process, you might want to check
the format of your results file.  The file format should match the specifications
described in Importing Student Scores.

Importing Scores from WebCT
Downloading From WebCT: Before information can be imported into MicroGrade, it must be
downloaded from WebCT.
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1. Login to your WebCT account and navigate to the Manage Students area.
2. From the Manage Students area click the Download button. The Download Student Record

dialog displays.

Download Student Record dialog

3. Change the Record separator from the default Comma to Tab.

IMPORTANT: WebCT cannot process names that contain a comma when the separator is a
comma because the standard quote protocol is not supported.

4. Click the Download button. The File Download dialog displays.
5. Click on the Save the file to disk radio button, and then click OK. The Save As dialog displays.
6. Enter a file name in the File Name text box, and then select the directory where you wish to save

the file.
7. Click Save when finished.

Importing Into MicroGrade: Once WebCT data has been downloaded, scores can be imported into
MicroGrade.

; NOTE: To import WebCT score information you must have an existing MicroGrade class with
the student information matching the WebCT class. The import process matches students
based on their ID numbers. You can achieve this by either uploading students from
MicroGrade or by downloading from WebCT.

1. From the Scores drop-down menu, choose Import Scores, and then click on WebCT. The Get
Assignment For Scores Import dialog displays.

2. From the Get Assignment For Scores Import dialog, choose an assignment to import scores into.
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Get Assignment For Scores Import Dialog

3. Click OK when finished. The Select a File of Scores to Import dialog displays.
4. Select the file that contains the scores you wish to import, and then click Open. The Specify

Import Fields dialog displays.
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Specify Import Fields Dialog

5. Select the field in the list corresponding to the assignment you want to score, and then click on it
so that it is highlighted.

; NOTE: MicroGrade automatically recognizes the field “User ID” and associates it with
the MicroGrade student ID.

6. From the Import Fields pop-up, choose Score.
7. Click OK when finished.

Exporting Information

MicroGrade’s General Export feature can export student and score information from your class file in
three formats:

• MicroGrade import format
• MS Word mail merge format
• WebCT format
• General export format

; NOTE: Exporting students from a class does not remove them from the original  class.
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Preparing your Export File
1. To export information from MicroGrade, from the File menu, choose Export.
2. From the Export hierarchical menu, choose General.

General Export Dialog

3. Define export fields from the nine drop-down menus: General, Student, Max Points, Percent,
Letter Grade, Raw Scores, Assignment Data, Attendance Codes and Student Attributes.
(MicroGrade automatically inserts double-angled brackets around each selected field).
Information will be exported in the order as it is appears in the text box. Use the cut, copy, and
paste keyboard commands to edit.

4. From the General Export dialog, choose Export.
5. From the Save Export Text dialog, choose to export the file in a MS Word Mail Merge Format,

WebCT Format or General Export Format by selecting the appropriate radio button.
Specify the following export information:
• Field separator: Choose to separate fields by tabs or commas.
• Include Quotes around field: Choose to Never include quotes, to keep required quotes or to

always include quotes around fields.
• Include field names record: Choose to include a header record defining field names.
Click OK when finished.

6. MACINTOSH: Enter an export file name and click Save.
WINDOWS: Enter an export file name and click OK.
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MicroGrade Import Format
MicroGrade’s General Export dialog also contains two buttons, Students and Scores, that format your
file so that you may later import to MicroGrade.

Students Button: Creates a standard file format including name, ID and notes.
1. From the General Export dialog, choose the Students button. The following export file format

will appear in the dialog’s text box:
<<Last Name>> <<First Name>> <<ID>> <<Notes 1>> <<Phone 1>> <<Phone 2>>
<<Gender>>

2. To specify students to export, click on the Students to Export drop-down menu and choose
Current Class or Your Selection.

; NOTE: When you choose Your Selection from the Students to Export drop-down menu,
the Select Students for Report dialog displays. Move students to the Selected
Students box to create a sub-set of your class.

3. From the General Export dialog, choose Export.
4. From the Save Export Text dialog, choose to export the file in MicroGrade Import Format, MS

Word Mail Merge Format, WebCT Format or General Export Format by selecting the
appropriate radio button.

Specify the following export information:
• Field separator: Choose to separate fields by tabs or commas.
• Include Quotes around field: Choose to Never include quotes, to keep required quotes or to

always include quotes around fields.
• Include field names record: Choose to include a header record defining field names.
Click OK when finished.

5. MACINTOSH: Enter an export file name and click Save.
WINDOWS: Enter an export file name and click OK.

Scores Button: Creates a file format including student ID and the raw score for a particular assignment
or category.
1. From the General Export dialog, click on the drop-down menu that appears to the right of the

dimmed Scores button and choose an assignment.
2. Click on the Scores button.
3. From the General Export dialog, choose Export.
4. From the Save Export Text dialog, choose to export the file in MicroGrade Import Format, MS

Word Mail Merge Format, WebCT Format or General Export Format by selecting the
appropriate radio button.
Specify the following export information:
• Field separator: Choose to separate fields by tabs or commas.
• Include Quotes around field: Choose to Never include quotes, to keep required quotes or to

always include quotes around fields.
• Include field names record: Choose to include a header record defining field names.
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Click OK when finished.
5. MACINTOSH: Enter an export file name and click Save.

WINDOWS: Enter an export file name and click OK.

Opening and Saving Templates
If you consistently export the same data/information for your class or students, you can save your export
instructions as a template.

1. From the File menu, choose Export.
2. From the Export hierarchical menu, choose General.
3. From the General Export dialog, define the information to export.
4. Again, from the same dialog, choose Save Template.
5. MACINTOSH: Enter a template file name and click the Save button.

WINDOWS: Enter a template file name and click OK.

Once you have created and saved an export file as a template within MicroGrade, you can retrieve it at
any time.
1. From the File menu, choose Export.
2. From the Export hierarchical menu, choose General.
3. Again, from the General Export dialog, choose Open Template.
4. MACINTOSH: Click on a file name and click Open.

WINDOWS: Click on a file name and click OK.
5. Your export format should appear in the dialog’s text box, review format text and then, click on

the Export button.
6. From the Save Export Text dialog, choose to export the file in MicroGrade Import Format (if

available), MS Word Mail Merge Format, WebCT Format or General Export Format by
selecting the appropriate radio button.
Specify the following export information:
• Field separator: Choose to separate fields by tabs or commas.
• Include Quotes around field: Choose to Never include quotes, to keep required quotes or to

always include quotes around fields.
• Include field names record: Choose to include a header record defining field names.
Click OK when finished.

7. MACINTOSH: Enter an export file name and click Save.
WINDOWS: Enter an export file name and click OK.

Exporting Information To Skyward
Using MicroGrade, you can export information for use with your Skyward system.

1. From the File menu, choose Export.
2. From the Export hierarchical menu, choose Skyward. The Skyward Export Options dialog

displays. Type in relevant information for all Mandatory Items, and select the checkboxes for
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each field you wish to Export. When you select a checkbox, select Grade Format and
Category/Assignment values from the drop-down menus to the right of the checkboxes. Click
Export.

3. The Export Skyward File As dialog appears.
MACINTOSH: Enter a file name and click Save.
WINDOWS: Enter a file name and click OK.

Skyward Export Options Dialog

Exporting Information To WebCT
Exporting From MicroGrade: Using MicroGrade, you can export information for use with WebCT.

1. From the File menu, choose Export.
2. From the Export hierarchical menu, choose WebCT. The WebCT Export dialog displays.
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WebCT Export Dialog

3. In the WebCT User ID section, choose from the following options:
Use MicroGrade Student ID – Click on this radio button to use the MicroGrade Student ID for
the WebCT User ID.
Use First Initial Plus Last Name - Click on this radio button for MicroGrade to generate the
WebCT User ID based upon the first letter of the students name together with their last name
converted to lower case; e.g., a student named John Smith would be given the ID jsmith.

; NOTE: If you plan to download data from WebCT and import it into MicroGrade you
must set this option to use the MicroGrade Student ID.

4. In the WebCT Initial Password section, choose from the following options:
Use WebGrade Password - Click on this radio button for MicroGrade to use the WebGrade
Passoword for the WebCT Initial Password.
Use MicroGrade Student ID - Click on this radio button use the MicroGrade Student ID for the
WebCT Initial Password.

; NOTE: If you use WebGrade in conjunction with WebCT, you may want to use the
WebGrade password so that your students have only one password to remember.

5. In the Students To Export drop-down menu, select from the following options:
Current Class - Select this option to export your entire class.
Your Selection - Select this option to choose specific students to export. When selecting this
option, the Select Students for Report dialog displays. Move students to the Selected Students
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box to create a sub-set of your class, and then click OK.
6. Click OK when finished. The Save WebCT File dialog displays.
7. Enter a file name in the File Name textbox, and then select the directory where you wish to save

the file.

; NOTE: When you choose to upload the file to WebCT you will look in this location and
select the file that you saved.

8. Click the Save when finished.

Uploading To WebCT: Once data has been exported from MicroGrade it can be uploaded to WebCT.

1. Login to your WebCT account and navigate to the Manage Students area.
2. From the Manage Students area, choose Import Student Data from the Select action pop-up, and

then click the Go button. The Import From File dialog displays.

Import From File Dialog

3. Click the Browse button and select your uploaded file.
4. Change the Separator from the default of Comma to Tab.

IMPORTANT:  WebCT cannot process names that contain a comma when the separator is a
comma because the standard quote protocol is not supported. Therefore, MicroGrade exports
WebCT data with a Tab separator so that names such as “John Smith, III” can be successful
uploaded to WebCT.

5. Click the Import button when finished.
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Averaging Classes

The Average Classes option under the File menu is available for those who used it in earlier versions of
MicroGrade and want to continue using it. For the newer, easier method of averaging classes, see
Grading Periods in Section 2. When you average classes, you import overall grades or category averages
(as percent scores) from two or more class files into a third “summary” class file. For each score
imported, a unique category in your summary class file must be created. For example, if you want to
average Class 1 and Class 2 into the Final Grade class file, create two categories in the “Final Grade”
class called Class 1 and Class 2. If you want to average categories as well, you must create assignments
for each category in each class file. For example, if Class 1 includes 3 categories (such as test, midterm
and term paper), these categories can be listed as assignments for the Class 1 category in your Final
Grade class file. You do not have to import every grade into the summary class file. Assignment scores
independent of class files (such as final exam) can be entered directly into the summary class file. The
scores you import are percent scores, so it is best to set the maximum points to 100 for each assignment
in the summary class. This way, you can specify each assignment’s weight toward the final grade just by
entering a percentage.

Student ID Required
MicroGrade requires student IDs to identify students when averaging classes. Each student must be
assigned a unique ID, which cannot change between classes. The best way to maintain student ID
numbers in new classes is to set up new classes by using the Save As command from the File menu. To
set up a new class, from the File menu, choose Save As, and select Option 2 from the Save As Options
dialog. Click Save, and enter a new class name in the resulting dialog, followed by the OK/Save button.
All of the student names and ID numbers are carried over into the new class. Repeat this process for
every class that you wish to set up for the averaging process.

Procedure for Averaging Classes
The best way to show you how to average classes is with a simple example. Let’s assume that you wish
to combine a student’s overall grade from two semester classes to compute the student’s final course
grade for the entire school year, as shown below.
(semester 1 + semester 2) divided by 2 = final grade

In this case, let’s assume you teach Math 100 and Math 101, and your students take both of the classes.
It’s now the end of the year, and you want to average the final grades for each class into one final grade
per student. To accomplish this, you must create a summary class for the two classes as follows:

1. Open the Math 101 class.
2. While the Math 101 class is open, from the File menu, choose Save As. The Save As Options

dialog appears. Select the Option 2 button.
3. Select the Save button in the Save As Options dialog. The Save As Options dialog disappears,

and the Save As dialog appears. Enter a new class name for the summary class, and select the
OK/Save button. For the sake of our example, name the new summary class Math Final.

4. You have just created a summary class called Math Final which includes the names and IDs of
the students in both the semester classes. Now it’s time to set up the assignments for the
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summary class. You set up one single assignment category for each class you plan on averaging.
5. From the Edit menu, choose Setup Categories. The Edit Categories, Assignments For Subject

dialog appears.
6. In the dialog, define two single assignment categories; one named Math 100 and the other named

Math 101. For each category enter a weight of 50% and a maximum score of 100 points.
7. Once you have entered the categories, tile all four of the MicroGrade windows (Student

Summary, Categories and Assignments, Class Scores, and Student Roster) so that they can be
seen all at once.

8. From the File menu, choose Save.
9. From the File menu, choose Average Classes. A dialog appears, listing all of the classes that are

currently defined on the right.
10. In the open dialog, select the class from which you wish to import grades. For the sake of our

example we will assume that the name of the first class you want to import is Math 100. Assume
that you selected Math 100 from the list box in the open dialog. The Average Class dialog
appears.

Average Classes Dialog

In the Average Classes dialog, the original class (from which you are importing) is displayed on
the left. In our example, the original class is Math 100. The summary class (into which you are
importing) is displayed on the right. The pop-up menu in the Copy field on the left allows you to
specify the information you wish to import from the original class. You can import either a
category average or the overall class grade. The pop-up menu in the To field on the right allows
you to specify the assignment into which you wish to import. In this example, you will import
overall grades from Math 100 into the Math 100 assignment of the Math Final summary class.

11. Select Overall Grade in the Copy field.
12. Select Math 100 in the To: field.
13. Select the OK button. An import dialog appears which displays the progress of the import,

including any errors. You can print or save the error report.
14. When you are done viewing the report, select the OK/Finished button.
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To import the second classes’ grades, repeat the above steps for Math 101 class. Note that this time,
however, you will select Math 101 as your import class, and import Overall Grades into the Math 101
assignment of the Math Final summary class.

Average Classes Dialog (with changes)

A Summary Class functions the same as any other MicroGrade class. For example, you can have up to
16 categories and 128 individual assignments within the summary class. You can adjust your grade
standards as needed, and you can setup assignments and enter scores. By using the weighted percent
grading method you can specify the amount each overall class grade contributes to the student’s average
grade.

Using MicroGrade In a Cross-Platform Environment
MicroGrade is available for both the Macintosh and Windows platforms. The program has been
developed in such a way that class files created on one platform can be moved to another platform.
However, due to implicit differences between the Macintosh and Windows operating systems, some care
must be taken if you plan to move your class files between platforms.

File Names
If you want to move MicroGrade class files from one platform to another, we recommend that you
create file names that both platforms can read. You will find that this applies when you move files from
the Macintosh to a Windows system. We recommend adhering to the following guidelines:

1. File names can contain up to eight characters.
2. File names should contain letters and numbers only.
3. Spaces, punctuation marks or special characters should not be used.
4. Do not delete file extensions generated by MicroGrade. For example, the Windows version of

MicroGrade uses the extension .cls to identify class files.
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; NOTE: If you are going to view a Macintosh class file using the Windows version of
MicroGrade, when the Windows version of MicroGrade prompts you to select a class file
to open. Remember to click on the List Files of Type list box and select All Files (*.*).

Fonts
If you plan to move your MicroGrade class files between platforms, use a font that exists on both
Macintosh and Windows. We recommend that you test the fonts you want to use by creating a sample
class file that can be viewed on both platforms. If MicroGrade encounters a font that it cannot recognize,
it will attempt to find its closest match.

Save As Function
Use MicroGrade’s Save As feature to make backup copies of your class files and to save your active
student roster and/or class structure.

1. From the File menu, choose Save As. The Save As Options dialog displays.

Save As Options Dialog
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2a. MACINTOSH: To make a backup copy of your entire class file, click the Option 1 button and
click Save. Enter a backup file name and click Save.
WINDOWS: To make a backup copy of your entire class file, click the Option 1 button and
click Save. Enter a backup file name and click OK.
-or-

2b. To create modified versions of your class file, choose formatting options by using the drop-down
menus and checkboxes available, or select one of the following special situations.

Option 1: Saves entire active class file (used to make backup copies).
Option 2: Copies student records from your active class but omits categories, assignments,

scores and grading information.
Option 3: Saves course information from your active class file but omits student records and

scores.

MACINTOSH: After selections have been made, click Save. Enter a new file name and click
Save.
WINDOWS: After selections have been made, click Save. Enter a new file name and click OK.

Transferring Students

MicroGrade allows you to transfer student information between class files. Student records, scores,
attributes, and attendance records can be moved easily from one MicroGrade class file to another. Use
the following steps to help you complete the transfer process:

; NOTE: Before you begin the transfer student process, you will need to have the class file you
will be transferring from and the class file you will be tranferring to available for use. If
you need to create a new class file to receive the transfer information, refer to "Creating
or Opening a Class File" or "Save as Function" in the MicroGrade User's Guide.

1. Open the class file that contains the information you would like to transfer.
2. From the Students menu, choose Transfer Students. The Select StudentsTo Be Transferred

dialog displays.
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Select Students To Be Transferred Dialog

3. From the Active Students list box, select the students you would like to transfer. You can double-
click on a student's name, click once on a student's name and use the arrow buttons in the center
of the dialog box, or use the arrow keys on your keyboard to select students for transfer. Student
names will appear in the Selected Students list box when selected for transfer.

4. Modify the selected students list by using the arrow buttons or by choosing Clear Selected
Students.

5. Click OK when finished.
6. The Select a Class File to Transfer Student To dialog will display. Select the appropriate file and

click Open.
7. A validation message will appear to notify you of any errors found. Click OK to proceed with

the transfer process. The Transfer Students dialog will display with any error information.
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Transfer Students Dialog

8a. If there are no errors in your transfer records, verify the checkbox selections listed at the bottom
of the dialog. These selections determine the additional information that will be transferred with
the student records you selected. When finished, click Transfer to complete the process.
-or-

8b. If there are errors reported, review the information listed in the dialog. Errors will usually be the
result of any inconsistences between your class files, such as differences in category and
assignment names and assigned point values. You can choose to print the error messages, write
the error messages to disk, cancel the transfer process or proceed with the transfer. If you choose
to proceed, you should carefully review the class file you transferred information to in order to
verify the information that was accepted during the transfer process.

9. When the transfer process is complete, close your original class file and open the transfer class
file to begin working with your transferred student records.

; NOTE: Transferred students are marked as dropped in the original class file. To restore a
transferred student to your original class file, from the Students menu, choose Student
Records. Click on the Edit Dropped Students button and restore a student by
highlighting the name, and then clicking on the Add button.
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